Author Topic: Invalid IDs in security group  (Read 2717 times)

Offline t_samanta

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Invalid IDs in security group
« on: August 28, 2008, 11:07:03 PM »
When I run 'Find All Invalid IDs' from Transpoter, it gives some invalid id against security group like as below:

Used In         Used In Element                                       Invalid Type
------------        ------------------------------------------------             ------------------
Groups          Administrative Staff\Active Access                table

I am not able to understand what the meaning of this output is.

Have you any idea regarding this matter?

Offline Sumit Sinha

  • Hero Member
  • *****
  • Posts: 110
  • Karma: +1/-0
  • Gender: Male
    • View Profile
    • Cognizant Technology Solutions
Re: Invalid IDs in security group
« Reply #1 on: August 29, 2008, 02:33:57 AM »
If you import an element that references an element that is not in the destination Business
Module or the element set being imported, then that reference (the invalid ID) is assigned
a NULL value. The Find All Invalid IDs command does not locate NULL values, and
therefore does not list these references after transport.

For example, if a table field added to a form is later deleted from the table, the
field remaining on the form references an invalid ID.

So basically for the above example, the field is
Used In:  the form
Used in Element: the field's path/location in the form
Invalid Type: the field

So, as per your example for the group invalid ID:
It means- if the table on which the group's connection type is based on is deleted, the group references an invalid ID.

So, you must check the base table on which these connections type's are based on (check Login_Types table). By default, the base table is either 'Users' or 'Contact_Web_Details'.
Or it may be that some of the tables having permission in that connection types have been deleted in customization but the changes are still not reflected in the security settings.

So i guess if you fix the invalid id for all the tables and fields listed, then this should fix up automatically.
« Last Edit: August 29, 2008, 04:57:54 AM by Sumit Sinha »
With Regards,
Sumit Sinha
Cognizant Technology Solutions